APs unable to use VLANs

I installed Unifi network several years ago and didn’t know anything about Unifi environment (I’m Cisco engineer) so I left everything default vlan1. If it was Cisco I wouldn’t use vlan1 but as I said I didn’t understand Unifi at the time.

All unifi devices are in vlan 1 (main network) as well as all host devices. The controller is running on Exsi windows server 2008 (I know super old but hey it works :wink: server is also doing DHCP and DNS. NG firewall is also Exsi VM. VM host passing all Vlans to VMguest. Switch port to the VMhost is configured for Native vlan Main network (vlan1) with Tagged VLAN Management “allow all”. Both the controller and AP are on same vlan1.

Last year removed USG router and started using Arista NG Firewall/UTM for routing.

Recently installed Unifi APs and everything works fine until I try to create Guest vlan for the AP to use.

I created network for guest to use vlan 80

Created WiFI network and assigned vlan80 to it.

Made sure switch ports the AP are connected to have vlan allow all.

Created vlan/SVI 80 in Arista NG.

Wifi agents can’t get communicate to NG in Guest vlan.

I checked on the switches the NG and AP connect to and see MAC of wifi client in vlan 80 and I also see the NG SVI interface in 80

80 xxxxxxxx 0/15 (AP) connected to Pro24-POE

80 00:xxxxxx 0/5 (NG) connected to XG-16 (great switch for the price; wish they still made it)

I finally tried moving my PC from main network (vlan1) which is also connected to the XG-16 to vlan 80 and I was successfully able to communicate to NG; out the ISP and also ping devices on main network. So it’s something with AP configuration.

Any ideas what I’m missing?

On the AP you just assign the ssid to the correct network vlan configured in the controller (third party vlan)

This will be a vlan network setting issue some where

Just make sure the switch port that the access point to connected is setup as a trunk (allows all vlans) , same applies to all ports connecting the switches

Are the clients on the wifi, getting an ip address ?

thanks for the reply.

OMG; when I was t-shooting earlier trying to figure out what was wrong and was missing with VLAN config on switch to the VMhost; somehow I must of change the uplinks to block all on the XG to pro24-poe; uplink ports are next to the VMhost link. Corrected uplink and now working.

I think I know what I did. I checked the uplinks then I clicked on port the VMhost is one and forgot to un-click the uplink when I applied the block all on the VMhost. oops