Adopting Unifi AP using unifi controller app on TrueNas scale

I’ve finally made the switch from Truenas core to Truenas scale. One of the main reasons why I waited so long was because I was worried if I could get the Unifi controller to adopt my Unifi U6 AP. Everything was working on Truenas Core with no issues.

First thing I did was reset the AP using the reset button on the AP before installing the Unifi Controller App from truecharts. I am able to log on to the Unifi Controller web interface from another computer. I have tried to use the Unifi Android app to get the controller to adopt the AP, I can’t seem to figure out how to use the android app to get the controller to adopt the AP.

Pertinent information

  • I am running unifi controller version Network 8.0.26
  • I am able to access the Unifi controller web interface from another computer.
  • the Unifi android app can see both the AP and the unifi controller
    • In the android app the AP the AP is reporting that it is pending adoption. When I click where it says pending adoption the Android app freezes.
  • Both the AP and the TN scale box are on the same subnet
    • the unifi controller app is using the Truenas IP address of
      • When I ran the unifi controller jail in TN Core the app ran on a seperate ip address? Can I not do this for apps in TN scale? Does it matter that on scale it is using the ip of the TN system
    • the AP has an IP of
  • the option Override inform host is set to the IP of the TN scale system in the unifi controller app.
  • there are no firewall rules preventing each device from communicating with the other
    • while SSH’ed into the AP I can ping the TN scale IP
  • while SSH’ed to the AP I issued the set-inform command:


the response from the AP:

Adoption request sent to ‘’. Use UniFi Network to complete the adopt process.

  • The info command on the AP is reporting a server reject message:

Status: Server Reject (

  • Should I specify a port? If so what is the port? Is the IP:port that I need to use not displayed in the Unifi controller app?
    • Should I use the port that is used to connect to the webgui (8443)?
      • I have tried using the set inform command with that port and got the same result.

How do I get the controller to adopt the AP?

Unless the inform port is 80, which it isn’t unless you have overriden it, you need to specify the port in the set-inform command. The default is 8080.


You can also think about using a domain name for the controller, that way if the IP ever changes, you just need to adjust the DNS entry instead of re-issuing the inform command at every single Unifi device.

The TN scale system does have a DNS entry, but the DNS points to the server itself and not the unifi controller. On Core it made sense to make a DNS entry for the controller because it has a separate IP address from the NAS. The unifi app on scale has the same IP as the TN scale box, so unless I can make a DNS entry that points to a specific port it no longer makes sense to give the controller its own DNS entry.

Also I am still getting a server reject error. How to I set the inform port in the Unifi controller software? If I can set it then I can be sure that I know the port.

I just did a port scan on the TN scale system using nmap. It appears as if the port 8080 is not even open. I’m new to TN scale, so I guess I need to figure out how to open ports on truechart apps.

The documentation just says to make a DNS entry that points to the unifi controller but only if the default port of 8080 is used, but the documentation does not say how to get the app to use port 8080. As I’ve said in the previous post, I did an nmap scan of the scale system and port 8080 is not open.

I cannot help with TrueNAS Charts as I’ve never worked with it. However, you mentioned you are able to use the web UI of the controller. If you didn’t have to configure anything special to be able to connect to TCP port 8443, I would assume the same logic applies to other ports like 8080.

That is not how DNS works and it’s also not true that there is no benefit of using a domain name even if the addresses for TrueNAS and Unifi are the same. Firstly, DNS takes a domain name and resolves it to an IP address. It has nothing to do with ports. Secondly, you can very well have two domain names that resolve to the same IP address, e.g. and It still makes your life much easier if the Unifi controller ever got a new IP address, which might be separate from the TrueNAS address.

have a look at

If port 8080 is not open, the above is not going to work- this needs resolving.

Instead of using Truenas App, way not spin up a debian virtual machine on Truenas and install Unifi. This is how I am running the Unifi controller

Thanks, I wish I had thought of that. That probably would have been way easier. I don’t know how I did it but I stayed up pounding my head in to get this damn thing to adopt. Sometime around 3:30am last night the AP and unifi controller finally decided to cooperate.

There were a few thing that I tried.

  • upgrading to the latest version of Truenas Scale
  • deleting the unifi plugin deleting the dataset that I had the uinfi controller software pointing to and switching to PVC storage. (Maybe there was an issue using the old config files)
  • the unifi android app,
  • resetting the AP to factory defaults using SSH instead of the pushpin button.
  • upgrading the AP to the newest firmware version. I believe that the AP already had the latest firmware version but I reinstalled the firmware to make sure.
  • Also what is suspicious is the fact that the Android app forces you to create a new wifi network when you set up a AP. I’m not sure if the AP then thinks it has been adopted at that point, but in the unifi android app I told the app to “forget” the AP.

I’m not exactly sure what I did to get the two to cooperate as it was around 3:30am and I went to sleep as soon as it adopted but this is what I believe finally did the trick. I am posting this in case someone else expediences the same issue.

Apparently the set-inform command requires you to put “http://” before the ip address, you can’t use “https://” and you can’t use omit “http://”. Before I just used set-inform <ip address>. When I did that I saw that the unifi controller would at least see the AP but then it wouldn’t adopt, giving me an “adoption failed” error with no information as to why the adoption process failed (good job ubiquiti). I continued doing “stuff” until it eventually adopted, I am sorry that I am light on the details as to what I did to get it to work but I honestly don’t remember and quite frankly I was just glad that I finally got this thing to adopt. My family would have strangled me in my sleep if we went another day without wifi.

So I guess I finally have this thing working.