3CX and Zabbix Agent

Hello All,
I run a Zabbix server within one of my local to me LANs and I run my 3CX server in the cloud. I was hoping to gain more insight into my 3CX server by connecting it up to my Zabbix server. Unfortunately I can’t get the 3CX zabbix-agent to successfully connect. After adding the host in the Zabbix web GUI the availability indicator turns red with the following error message: “Get value from agent failed: cannot connect to [[]:10050]: [4] Interrupted system call”.

I have a feeling there is something on the 3CX system (iptables?) that’s blocking me. I was hoping someone here has solved the problem I am up against before and can give me some tips as I have been working on it on and off for days.

NOTE: IPs have been slightly obfuscated

Zabbix Server
Firewall: Behind pfsense firewall. Port 10051 has been opened for the 3CX servers external IP
UFW: Port 10051 from the WAN IP of my 3CX server has been opened.
Local IP:
Server Web UI Host Config:
– Hostname: acsv (same as hostname on 3CX server)
– Groups: Linux Servers
– Interfaces: IP 10050
– Template: Linux by Zabbix agent
– Encryption: None (I plan on using PSK once I can get the connection to initiate)
– Enabled: Checked
Output of sudo ufw status numbered: sudo ufw status numbered (zabbix server) - Pastebin.com
Output of zabbix_server.log zabbix_server.log - Pastebin.com

3CX Server
Firewall: N/A
UFW: Port 10050 from the WAN IP of my Zabbix server has been opened.
Local IP: N/A
zabbix-agent Config:
– Server=,
– ServerActive=
– Hostname=acsv
Output of sudo ufw status numbered: sudo ufw status numbered (3cx server) - Pastebin.com
Output of sudo iptables -L -n: sudo iptables -L -n (3cx server) - Pastebin.com

Other points to note:
– The Zabbix server has no other hosts reporting issues. I have one other cloud VM hosted on the same platform (BuyVM) and it’s not reporting errors.
– tried installing the zabbix-agent from the built in 3CX customized source list AND through a direct .deb package. (installed fine but no change in connection) (tried this as one of last steps)
+ package URL: https://repo.zabbix.com/zabbix/5.0/debian/pool/main/z/zabbix-release/zabbix-release_5.0-1+buster_all.deb
– I usually use UFW instead of iptables since it’s easier for me to understand. Could this be causing conflicts?

What does your NAT rule look like in pfsense that points to your zabbix server?

Thanks for your reply xMAXIMUSx. I got it figured out. I needed to make some tweaks to /etc/nftables.conf and reboot.

I posted this on the 3CX forums as well and someone was able to steer me in the right direction.