XCP-NG XOA quick deploy Error

I did install XCP-ng without problems. but when i do try to auto deploy orchestra i get an error:

“code”: 1,
“message”: “INTERNAL_ERROR”,
“data”: [
“(Failure “Expected string, got ‘N’”)”

The only think i may think is a problem are i can´t select storage when deploying. i went back in to XCP-ng and did try to add an storage repository but can´t find any hard drives to use, did se it in the first install.

have tried to google the error but did not find much of use.

anyone any suggestions?

You should have been prompted to configure storage while installing, if there is no storage then Xen Orchestra can not install.

ok, i did chose the harddrive while install xcpng, but i guess i can just redo it and se if i did miss something.

Logon to the server with ssh (or putty from windows) as root and run;

xe sr-list

That should give you a list of the storage repositories that are configured on the server. You are looking for one with a content-type of user. If you don’t see one then you don’t have any storage configured for virtual machines (which XO is).

You could try;


to show you all of the available block devices and see if you can see the disk(s) you are expecting to see. You might need to add some partitions.

I could humbly suggest that the following video might help (as long as that’s ok @LTS_Tom )
(apologies for the lip sync)

1 Like

i did find the problem, the disc i did try to use did not become formatted in the process and because i have used it for Free-Nas disc before the system could not see it. i did make a manual format of the disc and now it works.

1 Like

Good news, glad you got it sorted.

1 Like