Upgrade to Truenas Cohiba & Kubernetes Broken?

Getting this error on my all of my apps (PVC and non). I tried usetting the pool on the apps page and rebooting as suggested elsewhere on the web. Didn’t seem to help. Going to boot back into 22.10 but wondering if anyone else has run into this and solved it. Example error below:

MountVolume.SetUp failed for volume “pvc-36da0d1c-841d-4a3e-9b1a-b8f6d0614024” : kubernetes.io/csi: mounter.SetUpAt failed to get CSI client: driver name zfs.csi.openebs.io not found in the list of registered CSI drivers

Update, reverted to 22.10.x, apps wouldn’t start at all. Deleted ix-apps data set, set apps back up manually. Lesson learned. I should back up the setting of each app before upgrading. Still curious why it broke but ended up brute forcing my way to working apps.

I think there was some issues if you either had an encrypted and unencrypted ix-applications (or maybe it was the reverse) the apps would break. There is a few posts in the TrueNAS forums about it.