Unifi Network Controller will not adopt Ubiquiti Access Points

Help on getting a Unifi Network Controller to adopt Wireless Access Points.

Brief description of situation

The Ubiquiti AP-AC-Lite has a fixed IP Address, and is on latest firmware (6.6.5). The Unifi Network Controller is running in a Docker container itself running on an XCP-NG VM. Followed the procedure for adoption - and it ends up being momentarily successful in that the UNC has generated a log message to confirm its adoption. But then it reverts to “Adopting”, and ultimately “Adoption Failed”.

There is advice on dealing with this situation on Unifi’s sites and many others, going back as much as seven years - presumably covering many different versions of the Unifi Network Controller and related devices. So not clear which of it is still relevant.

Wisdom please!


  • The drama enfolds in my home network, relevant items on a single subnet controlled by pfSense CE v2.7.1.
  • I had a single Ubiquiti AP (AP-AC-LR) for some time which has been excellent. I recently acquired a second AP (AP-AC-Lite) to help fill in some deadspots. Both APs are wired in; MESH options not in use. Both APs have worked well, having been set up via the Unifi Android phone app as stand-alone units. The APs have fixed IP addresses set up via Static ARP mappings on pfSense.
  • The Unifi Network Controller aka UNC (latest version 8.0.26) runs in a Docker container running in a VM based on Ubuntu 22.04 Server hosted on my XCP-NG v8.2.1 hypervisor
  • The UNC is accessible via a web browser using http:// on port 8443.
  • The UNC has been configured to set the “Inform Host” (Settings → System → Advanced) to “Override” with the IP Address and port number of the pfSense router.
  • The UNC works initially as expected, detecting existing Unadopted Ubiquiti devices

Adoption process

  • The UNC’s page for Unifi devices initially listed the two APs, showing their status as “Click to learn more”.
  • Started by pressing reset pin on the AP-AC-Lite for ten seconds or so until the LED goes off, indicating a hard reset
  • UNC shows that item with “Click to Adopt”
  • AP then goes thru various statuses, including “Adopting”, “Disconnected”, and ultimately “Adoption Failed”
  • It does apparently get adopted momentarily, as an entry goes into the system log to indicate that this has taken place. Sequence is like this:
    • The AP’s Properties panel briefly shows full attributes
    • Status goes to “Offline”
    • The logfile message to say successful adoption is created.
    • But seconds later the status goes back to “Adopting”, and the properties panel again shows the basic pre-adoption info of just MAC and IP Addresses

Other things tried

  • Once unit has been reset, logged into it via SSH with credentials ubnt/ubnt
  • There I have issued command
    set-inform http://UNC-ip-address:8443/inform
    This sometimes, but not always, reverts to say
    Adoption request sent to 'http://UNC-ip-address:8443/inform'. Use UniFi Network to complete the adopt process.

Are you able to adopt any devices ?

Instead of using docker version, try using a server version - Quick & Easy 5-Minute UniFi Self Hosted Debian 12 Controller Setup & Update Script [YouTube Release]

Also try having the AP on the same subnet as the controller so it bypasses any firewall rules.

Thanks for various inputs.

I have finally got it to work.

  • What changed
    • The key change (fairly sure) is that I changed the settings for the “Connectivity Monitor Type”
  • Where configuration is found
    • Bottom of the page Settings → System → Advanced
  • Details
    • The default value for this is the “Gateway” radio button.
    • I changed that radio button to “Custom” which allows entry of “Monitor IP Address”.
    • I put in the IP Address of the docker server where the Unifi Network controller system is running.
  • Note
    • The setting “Inform Host” is “Override”, with IP address again same as docker server

Unifi network controller now running:-

  • in a Docker container.
  • Docker running directly on an HP T-620 (small form factor mini PC usually referred to as a thin client device) set up to run 24/7 as a home server.