Stable Unifi Firmware

Good day
I have been trying a number of Unifi firmware for the Mesh AP, i tried everything in the 4.3.X range and seem to lose connection unexpectedly. The worst being the 4.3.24 firmware. Which one is the most stable unifi firmware?

We have them running current firmware and working. Are you sure it’s a firmware issue?

The current firmware is 4.3.24, and it has but on non-unifi DHCP servers. I tried 4.3.26 which is supposed to fix the issue, but I am still getting DHCP errors as well as others on the forum.
https://community.ui.com/releases/UAP-Firmware-4-3-26-11358/e05cd041-ea54-460c-85f4-7f3fd97261e8
Hostifi on their Twitter page, encourage users to downgrade to 4.3.21

Firmware version 4.3.21 is much better but still have some DHCP errors here and there. A number of people on the forums are recommending firmware 4.0.80 and below.

My setup is pretty basic, it’s 4 Unifi Mesh units(all cabled) and MikroTik RB951 router. I must admit issues start when I upgraded to the 4.3.24 firmware.

4.3.28 was released today, and says

UAP] Improve DHCP compatibility, especially when using third-party or non-UniFi DHCP Servers.

https://community.ui.com/releases/UAP-Firmware-4-3-28/0e023746-f08d-47af-8465-1c73b56dd4e9

Woow you guys are really on the ball. I am impressed, been looking forward to this version

1 Like

Unfortunately link is not working. I also checked on community dot ui dot com / releases and it seems not to be there. I will keep trying

Its a beta release, which means its hidden (gives a 404) unless you’ve accepted the Early Access agreement and are logged in.

https://community.ui.com/releases/UAP-Firmware-4-3-28/a02af414-6665-4c57-ac03-6e4dac8317e1

4.3.28 now available for the general public

Overview

  • This release is only for the devices seen in the download links.

  • This release is available on the Release Candidate firmware update channel.

Improvements

  • [UAP] Add support for adoption of UniFi SmartPower Strip (Early Access).
  • [UAP] Improve DHCP compatibility, especially when using third-party or non-UniFi DHCP Servers.
1 Like

Is it resolved? I’m still not sure if we are gonna update our firmware…

I had challenges with version 4.3.24 and 4.3.26. I updated my 4 Unifi Mesh about 12 hours ago to firmware version 4.3.28 and they have been working really great. Big thanks to the Unifi team for fixing that bug. My gateway router is a mikrotik RB951 and it’s also the DHCP server. I am monitoring the DHCP logs using Promtail and Loki, and I am using Grafana for visualizing the logs.
Grafana visualization for the past 12 hours. I install firmware 4.3.28 at around 19:30 and it’s been running really great. You can give it a try. I will also advise having a look at the unifi community on the following link

https://community.ui.com/releases/UAP-Firmware-4-3-28/a02af414-6665-4c57-ac03-6e4dac8317e1

1 Like

I manage client devices from a Unifi controller at my office running on a Windows PC. Over the last few days I have been troubleshooting the following sporadic problems at more than one site.

  • Wireless laptop Users who couldn’t obtain an IP

  • Mobile devices that couldn’t connect or couldn’t obtain an IP

The problem was sporadic, sometimes affecting Android but not iPhone mobile devices, sometimes laptops were working but mobile devices weren’t. I checked to make sure that all Unifi WAPS and switches were on the latest firmware and that I was running the latest controller, no USG or UDM. Checked DHCP on the DC although wired devices were never affected. SSID “[client name] Private” is not on a separate VLAN. Ran through all the troubleshooting steps for each device type. Sometimes it worked for a while, other times not. I finally found this post; https://community.ui.com/questions/UniFi-6-0-4314348-Clients-Dropping-DHCP-DNS-connectivity/144ce663-78d2-438c-bc69-e053fd44df6a Using the link RobbieH provided I rolled back all WAPS (UAC-AC-Pro) to 4.3.20 at 3 sites. So far the problem seems to be resolved.

I’ve looked at the USG and UDM, I’m underwhelmed. I hope Unifi does a better job of making the firmware of their WAPs and switches standards compliant.

1 Like

Thanks Cirrus for your participation and help!

Feedback from end users has been 100% positive. I have not found it to be necessary to roll back the switches so far. I plan to be proactive, will roll back all WAPs at all sites tonight.