Speed Issues on gig fiber

Just had AT&T Fiber installed. 1000Mbps full duplex. Results are underwhelming and I know it’s something I’m doing wrong. Tech who installed connected to the AT&T wifi with his iphone 12 and got 800+ both ways granted both devices are wifi6 compatible.

I put the AT&T modem/router in pass through so I can use my pfsense router. I have two ESXi hosts - one is a 2012 Mac Mini running 6.7 and the other is an HP z440 with a quad port intel NIC. VMs on the mac mini are pushing 600-700 on a speed test. On my HP server, 150 at most.

For wireless clients, i have an iphone X and a 2015 MBP - both are 802.11ac. but the best i’ve been able to achieve on either has been in the 200-250Mbps range. Unless I’m mistaken, 802.11ac connections should be easily in the 450 range?

I’m at a loss. Everything in ESXi on both servers shows 1000Mbps.
the ports that both servers are configured to in Unifi are the same and both show 1000Mbps capability.

Any assistance would be greatly appreciated.

What hardware are you using for the pfsense router? Is it capable of routing that fast?

1 Like

Hey Tom,

Its an HP thin client with an added 4 port NIC
EDIT: Finally found the ebay purchase. Exact model is: HP T620 Plus WES7e Thin Client
AMD GX-420CA SOC with Radeon™ HD Graphics
4 CPUs: 1 package(s) x 4 core(s)
HP NC364T Quad Port Gigabit Ethernet Adapter Card 1Gbps 436431-001 435506-003
Running 2.4.5-RELEASE-p1 (amd64)

All interfaces show 1000 full duplex

switch that both servers and pfsense box are connected to:

A VM on the Mac Mini server was speed testing at 700Mbps

VM on the bigger HPZ440 server won’t do anything over 200

Both route through the same pfsense box

To rule out a routing issue you can setup iperf on the pfsense and see how fast raw transfers are happening. You might have some NIC card comparability issues.

1 Like

Installing iPerf from package manager now. Not familiar with it but will do some googling tonight.

this could take longer than anticipated… iperf isn’t installing…

been sitting like this for at least 30 min. i’ll reboot and see if that changes anything. worst case scenario i suppose i’ll have to bite the bullet and upgrade to 2.5.1

I am not 100% sure if I’ve done this correctly but here are the results:

I set pfsense to run iperf in server mode. then ran iperf -c to the pfsense box from my MBPro. Ran the test several times with similar or worse results.


To add to the confusion, my wife’s 2013 MBpro (mine is 2015) has WAY better results on speed tests both wired and wireless

I know you’re probably swamped and I don’t mean to be a pest but I wanted to follow-up and see if you had any other thoughts on this? Thank you in advance.

Not really a problem I have ran into before, maybe try their forums https://forum.netgate.com/

All I can say is that I have the exact same thin client for my home lab pfsense box, but because I have junk Spectrum ISP, I only have 70mbps/6mbps so can’t give you any comparisons. I can easily fill the ISP connection at home and not even get close to your levels of performance.

What I would do is boot the Z440 from a linux live disk, and check performance again, there may very well be something with ESXi that is getting in the way. If it continues to be slow, I’d change the NIC card or try the onboard NIC to see what is happening.

Can you try the onboard NIC through ESXi? That might be a place to start.

Thank you none-the-less. I’m not convinced it’s a pfsense issue yet but I’ll keep this in mind. Cheers!

I can test this but it’s not specific to the z440. My mbpro tests slow but my wife’s tests fast. I’m going to create a spreadsheet of test scenarios to try to help narrow down the issue. I’m still not sure if it’s my laptop, my unifi set up, or pfsense, a port, NIC, or some weird combination. If i figure anything out, i’ll post it here for posterity.

Just found something interesting… when I do a speed test in Chrome or Safari, it is consistently twice as fast (or more) than FireFox (my default browser) on the same computer with no other changes.

I just tried a firefox test from work, but not a good test from here. 750mbps down and 350mbps up through my firewall and the campus firewall, only a 1gb connection to the router. I normally see something similar through Chrome

I have seen this before (but over a year ago). If memory serves with some AT&T fiber modems they throttle you at a lower speed (and it may be 100Mbps) when you put the modem in bridge mode. There were goofy work-arounds, but I think I wound up putting the firewall in the modem’s DMZ to get around this. We later replaced with a model of modem that didn’t have this problem.


I don’t use UniFi gear, but I have tested with two separate Orbi mesh setups, their consumer WiFi 5 version, and their WiFi 6 “Pro” solution. Sure, these devices have a theoretical throughput of over a gig, but in practice, in my neighborhood with so many APs around, I typically get about 350Mbps over the AX6000 Orbi, and the older one gets in the 200s at best. A wired connection through either Orbi results in full gig line rate to my ISP and beyond. That’s perfectly fine for most client device usage and it’s still in place. For serious file transfer work with my 2 NAS, I have those plugged into a Netgear ProSafe all 10G RJ45 switch along with the hosts who need that speed. That traffic doesn’t even hit my wireless.

interesting results. perhaps its something with my specific firefox setup… i may try a reinstall with no addons

not disputing your results at all but it seems unlikely to be my problem since my wife’s laptop has “normal” speeds" and my laptop (using firefox apparently) doesn’t. i need to sit down and put an excel table together with testing results to help shed light on where the problem is. i’ve also got one server (a mac mini) that just blows along at full gig speeds and my HPz440 that moves about as fast as i do…

Ahh, apologies if I didn’t pick that up in my review of the thread. I certainly have had machines where one browser did well on speed tests and another was terrible (both wired and wireless). I’ve also had a Windows laptop that just always did terribly. Whenever possible I start with a wired test just for a sanity check.

1 Like