Routing Error :radvd 40776 sendmsg: Permission denied

I have a new pfsnese build but my routing logs are getting flooded buy “radvd 40776 sendmsg: Permission denied” about every 10 seconds. Can anyone help figure out how to stop this from happening.

Try disabling IPV6, that solution has solved that in other posts

In System > Advanced > Networking

Allow IPv6 is unchecked

IPv6 over IPv4 is unchecked

Prefer IPv4 over IPv6 is checked

IPv6 DNS entry checked

As far as I know that is turning off as much IPv6 that I can think of, is there something I am missing?

Make sure under services you have both the DHCPv6 Server & RA & DHCPv6 Relay off.

Just checked both DHCPv6 and DHCPv6 Relay is turned off. Unfortunately still this in the routing logs

|Aug 7 03:07:16|radvd|40776|sendmsg: Permission denied|
|Aug 7 03:07:24|radvd|40776|sendmsg: Permission denied|
|Aug 7 03:07:30|radvd|40776|sendmsg: Permission denied|
|Aug 7 03:07:37|radvd|40776|sendmsg: Permission denied|
|Aug 7 03:07:44|radvd|40776|sendmsg: Permission denied|
|Aug 7 03:07:52|radvd|40776|sendmsg: Permission denied|
|Aug 7 03:08:01|radvd|40776|sendmsg: Permission denied|
|Aug 7 03:08:10|radvd|40776|sendmsg: Permission denied|

Weird, might want to try the Netgate forums as it’s not an error I have had before.

Ok, thank you for trying. Great place you have here. And your videos are really the best! Thank you for all you do.

1 Like

I noticed this error also in the new RC build.
Solution: go to Services -->DHCPv6 Relay → tab Route Advertisment and there disabled it.

The error message wil stop.