Proxmox 7 to 8 upgrade issue

Updated proxmox from 7 to 8. Everything went (seemingly) went well. After doing the final reboot, I re-ran proxmox7to8 and got the following warning

“A suitable kernel (pve-kernel-6.2) is installed, but an unsuitable (5.15.30-2-pve) is booted, missing reboot?!”

I’ve rebooted several times… I ran the following commands to try to pin the new kernel… it shows the new kernel is pinned but never boots into it…

pve-efiboot-tool kernel pin
proxmox-boot-tool kernel pin

Has anyone else seen this?