Problem with nextcloud in haproxy

Hello folks,

I run the latest non dev. version of pfSense and all is running fine.

i use haProxy as a reverseproxy, and it also works fine.

but now i tried to add one more to haproxy, but that domain does not work.
Is there anyone who can help with that ?

Greetings

here some info.

Certificates are on Point, Haproxy is copied from the other domains.

Server ip and port are correct. Accesslist in pfSense aswell.

And the error.

billede

Without seeing the details, I would guess that you don’t have the back end configured correctly.

well, the nextcloud instance run as a docker container and uses the default http setting on port 80, i have redirected the port within docker from 325 (dockerhost) to 80 (container)

and here the backend config in haProxy

Does it work if you go to http://192.168.166.10:325 or https://192.168.166.10:325 ?

yes, http://192.168.166.10:325 works right away. but not from the outside. And the host has not even a firewall active right now, not even the ufw is active. :frowning:

Did you add the haproxy address as a trusted proxy within nextcloud’s config.php?

Any log files that might give you a clue on what’s going on?

1 Like

Okay, got it to work, but I am not sure how, I just deleted the container and created it new, with exactly the same settings… but it works now. :slight_smile: