Pop OS 20.04 issues

Hi all,

I’ve been using Pop OS 18.04 for well over a year as my main OS on my laptop without any issues. I went to upgrade to 20.04 a couple days ago and ran into a couple issues. Curious if anyone has seen any of these or has any ideas.

  • WiFi won’t connect to secure networks (BCM 4350 card in 2016 Dell XPS13)

Since I upgraded, my networks and WPA2 were stored in the machine but it would not connect to them and kept prompting me to reenter my password. I setup another secure network via my phone’s hotspot and it also wouldn’t connect. I changed my home network to an open one and it was able to connect without an issue. I’ve tried installing / uninstalling a number of drivers per this page (https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx) but it didn’t work. Also as of now, the OS isn’t even finding the WiFi card. Any idea what wifi driver comes with the basic 20.04 install?

  • Getting stuck on the “cryptsetup: cryptdata: setup successfully” splash screen after entering disk password.

This seems to have happened after a kernel update I believe since I’m able to get around it if I hit the space-bar during boot up and select the previous kernel.

If anyone has any ideas or suggestions, I’m all ears. I also took an image of my drive and tried doing a clean install of 20.04 this morning to see if that would help but accessing secure WiFi networks was still an issue. I’m in the process of restoring the image so hopefully I’ll be able to figure these issues out in the next few days. Otherwise I’ll end up going back to 18.04.


Since I had a backup of everything, I did a fresh install of Pop OS 20.04 to get around the drive encryption hanging up after I entered the password.

Although, I’m still having the wifi issue. I’ve been chatting with a few on chat.pop-os.org, but so far no one has been able to help with the wifi issue. Digging a bit more today I noticed the following which I think is pointing to an issue, but I’m not sure where to take it from here.

45.385245] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac4350-pcie for chip BCM4350/8
[ 45.387589] brcmfmac 0000:3a:00.0: Direct firmware load for brcm/brcmfmac4350-pcie.Dell Inc.-XPS 13 9350.txt failed with error -2
[ 45.387606] brcmfmac 0000:3a:00.0: Direct firmware load for brcm/brcmfmac4350-pcie.txt failed with error -2
[ 45.397505] r8152 3-1:1.0 eth0: v1.10.11
[ 45.831919] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac4350-pcie for chip BCM4350/8
[ 45.831950] brcmfmac: brcmf_c_process_clm_blob: no clm_blob available (err=-2), device may have limited channels available
[ 45.832245] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4350/8 wl0: Oct 22 2015 06:16:26 version (r594535) FWID 01-e791c176

Figured I’d follow up on this. So digging a bit through various forums, I found complaints about this laptop / wireless card having the same issues I was seeing starting in Ubuntu 19.04 and still with 20.04. As of the last post I found no one had any fixes that worked. I also reached out to @JayTheLinuxGuy on twitter and he had the idea of just swapping out the wifi card as the easier solution. I picked up an Intel AC 9260 for under $20 on Amazon and it started working as soon as I put it in. I still have no clue what the issue was, but spending $20 was a way easier way to fix it.