Pfsense Fiber WAN - VLAN assignment

Hello, everyone,

I got my new fiber connection. For configuration, this requires that the WAN interface is tagged with a VLAN tag and that my customer number is entered in the DHCP host name.

The problem is, all the guides for pfsense I could find tell me to create a VLAN with the provider VLAN tag and the WAN-port as parent interface, but not add it. You should then assign the created VLAN as a network port to your native WAN. And that’s exactly what doesn’t work for me. I can select the network port (the created VLAN) on the WAN, but when I save it, it always falls back to the native port. I can’t figure out why it’s not working.

Maybe someone of you knows this problem and has a solution, thanks.

have a look at https://jarrodstech.net/how-to-pfsense-provider-wan-vlan-tagging-with-sg-1100/

Set the wan to be dhcp, and add your customer number into Hostname.

1 Like

Thank you, my problem was in step 3 of the instructions. I was able to select my created VLAN on the WAN “network port” tab. But when I saved, my native port was back as the network port on the WAN. The error was because I had to deactivate the WAN interface first. (Uncheck “enable interface”). After that I was able to save and it assigned the VLAN as a WAN network port. Then, I enabled the WAN interface again and restarted the pfsense. Now everything is working as it should

Many Thanks