OpenVPN on mobie/android connects but I can't access anything over browser, but when on a foreign WiFi it's fine

Are you using DNS from your own pfsense or are you using assigning a public DNS server in your DHCP setting for your OpenVPN interface?

If you use internal DNS you have to set an ACL on the DNS resolver inside pfsense. Navigate to Services > DNS > Resolver > Access Lists the click on Access List tab and add your tunnel network subnet like below

Save and apply changes.

I assume your network mask is the ip range of your OpenVPN?

Here’s (what i think is) the relevant section of my OpenVPN configuration:

and here’s the settings for the DNS Resolver (DNS Forwarder is NOT enabled):

LMK if anything else would be helpful to aid in diagnosing. I’m thinking about pasting all my OpenVPN settings in a separate post, cause i’ll be honest there’s a bunch in there i don’t understand…

Your second screenshot looks to be incorrect for you DNS settings. You have and your access list is which are 2 different subnets.

You’ll need to set your DNS to the same subnet as your IPv4 Tunnel Network settings in your openvpn in the access list.

My Config



DNS Resolver Access List

So i made the following change per your suggestion:

Will i need to reload the certificate in my android client? testing from home with my wifi turned off, i was, eventually, able to pull up a website or 2 (it was extremely slow) but not my pfsense UI @ Is there further configuration needed to “link” the dns at to the main one @ I have localdomain under DNS Default Domain, but am not sure what you greyed out…

Feels like progress though!

Your gateway ( is already tied to your DNS resolver. Whatever can query for DNS, so will

excellent thanks for clarifying. Any idea why i still can’t connect to WebUI in my browser then? Should I just post all my OpenVPN settings for clues?

edit: also tbc, it seems like pretty much any webpage i try eventually pulls up so it’s definitely moving in the right direction, it’s just VERY slow and I can’t bring up local servers GUI on local ip addresses (e.g.

Its slow because you probably have all traffic forced through your VPN and either cellular internet or home internet is slow.

If you want it faster you have an option to split tunnel which means you can access the internet just as you normally would by the phone going to a site without going through the VPN tunnel and when you request to navigate to your pfsense web GUI for example you will be able to reach it.

If you want split tunnel follow below.

I’ve made the following change:

the ipv4 Local Network was already populated that way an I had Redirect IPv4 Gateway checked but the IPv6 Gateway already unchecked.

unfortunately with these new options I still don’t have the ability to access local IPs GUI’s. Will I need to reload the certificate?

I have gigabit AT&T Fiber at home, and experience no speed issues at home. The cellular network on the other hand could be the culprit. It used to work flawlessly, even before i had fiber (and while on it), I wonder what changed…

I feel like there is something to my internet connection after I connect

Speedtest run when not connected to the OpenVPN returns very reasonable speed. When connected to openvpn the speed test won’t even run…

I think i fixed it!

Added this:

from this thread
which is from a person that was experiencing a similar problem: OpenVPN over Google Fi stopping working about 10 months ago. So fingers crossed this was the issue…