INVALID VDEV after TrueNASCore update

Ive been looking for a way to solve this issue for the last week, but i couldnt find a way .

Last monday night i performed a truenas core upgrade from 13.0 to 13.0U1.1 and the server didnt came back online after reboot.
I reboot it locally, it reached the menu options with local ip displayed correctly but no access to webUI or Shares.

I tried to boot with a previous version, i think i used 12.0U8. The server hanged during boot.

I restarted and tried to boot with 13.0.U1.1 again, but did not reach the menu, with this error displayed:

Now, every time i boot, i get this error, using 13.0U1.1 - 13.0 - 12.0U8

What i tried to fix it:

  • I used a fresh Core install in a new boot HDD, and i tried to import the Pool. It hangs during “importing pool” (48hs later, no change). After restart, same INVALID VDEV error
  • I used a new computer, with new cables and tried to import the Pool, same result, Hangs and VDEV error

I dont know that else i could try. All similar errors i could find were related to failed drives and its replacement.

Thanks in advance, Nicolas

If the pool won’t import from a fresh load with the the latest version I am assuming the ZFS data is too corrupted to bring back in.

Thanks for your answer!!!

Could this just happen becouse i started a truenas 12 on an upgraded truenas 13 zfs pool?

Very unlikely, the most probable answer is that there was some pending issues that the reboot brought to light.

Thanks for your help, I end up creating a new pool destroying the data

How often do you scrub your pool normally?

If it was a long time ago, there might have been errors all along. Also might be wise to enalble checksums if not already done.

i cant remember changing the default scrub schedule

i ll see what settings i have

Thanks!