How to set Port forwarding on this network setup

Hello, im having a problem using port forwarding on pfsense
this is my network setup.

ISP dynamic IP , modem : DHCP enabled 192.168.1.0/24
Pfsense : WAN Interface DHCP enabled 192.168.1.1
LAN 172.16.1.0/24
Device: 172.16.1.2 - laptop
172.16.1.3 - CCTV server

my goal is to portforward the CCTV server, but my WAN IP is 192.168.1.1 on pfsense
how can i forward it if my WAN IP is private?

You need to do that on the ISP router.

Thanks for the reply sir,

is there any possible way to set my WAN interface to get my public ip on the WAN interface instead of the DHCP from my ISP router.

You need to check with your isp. Sometimes you can use dmz mode on some routers.

Maybe you can see if they have a modem only option vs a modem router. Does your connection come in rj45 or other?

Sometimes it is referred to as “full bridge mode”

Yes my ISP provider is fiber backbone modem then rj45 to pfsense

As @pmik76 stated – can’t you put your ISP routers into bridge mode and bridge your internal router with the ISP router?

Looks like your double nated. Either port forward all ports on your isp to pfsense so then your pfsense is the master, port forward the necessary ports or try to for modem only/bridge mode. What isp are you using?