Help with xcp-ng

#1

I installed xcp on my server and connected to it through xcp-ng center. I followed Tom’s video for my first vm. But upon installing I run into issues on every install. Somtime it wont even load the iso right other times I can get through Install then I get a black screen that says somthing like hard disk boot success but xant get past that. I cant seem to get vms running right, any ideas would be appreciated.

#2

screenshots? logs? even the events of xcp-ng center would help

#3

Ok will post tonight

#4

I had this problem before. It ended up being pfsense blocking the connection. I didn’t specifically allow the 443 port to XCP-NG from my computer (which was on a separate interface / subnet). I am thinking this is not your problem but I figured it wouldn’t hurt to have you double check since I had the same symptoms.

#5

So I compiled xen orchestra from source and got a debian box running but every other box I have tryed either ends up freezing right before install completes or it completes but cant get past this black screen. I’ve tryed more CPU and ram and multiple installs. The only difference in the working and non working boxes that i can tell are that i chose other for template when making vm…?pop OS showed a blank black screen from beginning too… also I do have pfsense running. But I’ve got one machine to work just none of the others…20190426_231701|690x335

#6

#7

@sysman923 any thoughts?

#8

Hmm odd…I hesitate to say this but have you tried a windows 10 machine? Bios update on the physical box? What are the specs of the machine?

I apologize for the late response I’m away right now, no worries tho I’ll try to help out.

#9

@sysman923 so I got the kali linux box to work by switching VGA on in advanced settings… but ubuntu is still getting froze after I do a install then restart ,it starts to boot but then it will say somthing about waiting for boot to finish up. I’ll get more screenshots and check bios and specs today. It’s a older supermicro x8 workstation. Thanks

#10

are you using local storage or shared?

#11

There not much to go on here sorry.

It sounds strange.

Recommend trying local storage ext for test.

Maybe also review XCP-NG Centre it requires Windows (Virtual box). You can do test just to review if you get the same problem.

If it does not work I have used the XCP-NG forums. They have really helpful community you can ask your questions there.

Additional Note:
Useful Screenshot tools for showing your issue Shutter & Peek