FreeNas CloudSync to OneDrive

I have been playing around with the cloud sync tasks and getting some data offsite and I am running into a snag. At first when I setup the task everything seemed to run fine until the end of the task and it failed “rclone failed with exit code 1”

After this I deleted everything and started from scratch including a new dataset. Everything seemed promising up to the point I checked my OneDrive and there was no data at all despite the task reporting that it ran correctly; in fact the task actually was uploading somewhere. Task Running

I am really perplexed at this point what could be wrong? I called Microsoft and they claim that the OneDrive account is fine, and when I upload files to this account in any other way, everything is showing up fine. Authenticating to the account is not a problem everything checks out on that end as well.

I tried this numerous times with different setting and files etc. The cloud sync task at this point is a simple as it can get with no extra settings or encryption and no matter what I do I get the same outcome. Any direction in getting this figured out is always appreciated.

Do you have another Linux box to try rclone independent of freenas? Rclone worked for me on my pi with no issues. Wondering if something in the setup for freenas is the issue.

Maybe permissions? I have had permissions issues on Dropbox in the past. Wondering if you can do an offline test to confirm that one drove working properly.

So it very well might be permissions, The strange thing is that I am able to backup and do a restore of the files. So I have a user:chris group:chris that is assigned to the dataset and from there I have a smb share. When I delete everything from the folder and perform a pull command I get all my test files that I don’t see in the OneDrive GUI back except they are owner root so user chris cant see the files in smb but if I chown from cli and change owner all files appear. Am I setting this up wrong? Below are my Dataset ACL that correspond to SMB as well

@techman2005 unfortunately I am unfamiliar with freenas currently so I can’t answer the acls question. Definitely sounds like you are getting closer and permissions could be the issue.
I have had permissions issues with cloud services in the past.

So this is even more strange I really don’t know where Freenas is sending my files, I setup a test Ubuntu install with rclone and rclone browser and when I connect to one drive my files are not there but when I connect from FreeNas (both are using same creds) I am able to get the files FreeNas uploaded originally as a test around 953MB, Both rclone browser and one drive web gui show the account empty? It seems like its uploading to the wrong account but its using a different drive ID and same creds.