Database on shared nfs storage via 10GB Network

Hi Guys,

I’m having some issues with one of my setups. I’ve just upgraded to 8.2 from 8.1, but think this is happening regardless of the version. Its a bit sketchy because I don’t have any direct evidence, but…

I recently migrated all of the VM’s from one host to the other live so that I could upgrade to 8.2.

The storage is a truenas box and the storage network is 10GB SPF+.

Some time after this, I discovered that one of the firewall machines would no longer update, and closer inspection showed a heap of inode errors. I rebooted to a rescue disk and tried to fix them, but to no avail (it was based on Ubuntu).

I restored from a backup and so far so good…

However, I’ve now discovered that all of the postgresql servers that were running on the shared storage are now throwing errors eg…

2020-12-05 20:35:25.721 AEST [2093977] ERROR:  invalid page in block 1212 of relation base/16387/18248
2020-12-05 20:35:25.721 AEST [2093977] CONTEXT:  automatic vacuum of table "emms.public.predispatch_fcas_req"

and so I’m going to have to rebuild them by the looks (luckily only the test ones are running on the shared storage). The production databases are running on local storage and seem to be OK.

I should also say that I ran MYSql databases like this for years and didn’t have any issues that I know of.

Are there any known issues with running databases across NFS? Should I perhaps be using iSCSI instead, or is this just a bad idea in general?


NFS or iSCSI are fine, I would make sure there is not any issues with the network gear because no matter what the transport protocol if the network connection to the storage is having issues it can cause broken drives.